Investigating connection issues with the Store

Major incident Store
2023-04-17 08:48 CEST · 36 minutes

Updates

Resolved

The issue has been identified and fixed.

April 17, 2023 · 09:24 CEST
Investigating

We are currently investigating an issue with the connection of the Store. We keep you updated.

April 17, 2023 · 08:52 CEST

← Back